CISCO HyperFlex Software parancs befecskendezéses sérülékenysége

CH azonosító: CH-14723
Cím: CISCO HyperFlex Software parancs befecskendezéses sérülékenysége
Angol cím: CISCO HyperFlex Software Command Injection Vulnerability

Publikálás dátuma: 2019.10.24.
Utolsó módosítás dátuma: 2019.10.24.


Leírás

A CVE-2018-15380 számon a Cisco HyperFlex Software-en futó cluster service manager magas kockázati besorolású sérülékenysége vált ismert, amelynek sikeres kihasználásával a támadó root felhasználói jogosultsággal futtathat parancsokat.


Leírás forrása: Gyártói referencia: tools.cisco.com
Leírás utolsó módosítása: 2019.10.24.


Elemzés leírás

A Cisco HyperFlex Software-en futó cluster service manager egyesíti a Cisco UCS-t (Unified Computing System), illetve az egyéb tárolási és adatszolgáltatási szoftvereket. A sérülékenységet a  felhasználó általi adatbevitel nem megfelelő validációja okozza.

A kihasználáshoz a támadónak fel kell csatlakoznia a cluster service manager-be, és a bound folyamatba kell parancsokat küldenie. Sikeres támadás esetén a támadó az érintett eszközön tetszőleges parancsot hajthat végre root felhasználói jogosultsággal.

Érintett Szoftverek:

  • Cisco HyperFlex Software 3.5 és előtti verziók

Megoldás:

A gyártó cég honlapján közzétette a hibákat javító szoftverfrissítést.


Elemzés leírás forrása: Gyártói referencia: tools.cisco.com
Elemzés leírás utolsó módosítása: 2019.10.24.


Hatás

CVSS3 Súlyosság és Metrika

Alap pontszám: 8.8 (Magas)
Vektor: AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Hatás pontszáma:
Kihasználhatóság pontszáma:


Támadás Vektora (AV): Szomszédos
Támadás komplexitása (AC): Alacsony
Jogosultság Szükséges (PR): Nincs
Felhasználói Interakció (UI): Nincs
Hatókör (S): Nem változott
Bizalmasság Hatása (C): Magas
Sértetlenség Hatása (I): Magas
Rendelkezésre állás Hatása (A): Magas

CVSS2 Súlyosság és Metrika

Alap pontszám: (Nincs)
Vektor:
Hatás alpontszáma:
Kihasználhatóság alpontszáma:




Hivatkozások

Gyártói referencia: tools.cisco.com
Egyéb referencia: nki.gov.hu
CVE-2018-15380 - NVD CVE-2018-15380