phpMyAdmin CSRF sérülékenység

CH azonosító: CH-14621 Cím: phpMyAdmin CSRF sérülékenység Angol cím: phpMyAdmin Cross Site Request Forgery Vulnerability

Publikálás dátuma: 2019.06.27.


Leírás

A phpMyAdmin alkalmazás sérülékenysége vált ismertté, amelynek kihasználásával Cross Site Request Forgery (oldalon keresztüli kéréshamisítás) támadás indítható a felhasználók ellen.

Leírás forrása: Egyéb referencia: nvd.nist.gov


Elemzés leírás

A program nem megfelelően ellenőrzi a HTTPS kéréseket, ezt a hiányosságot kihasználva hozzáférést szerezhet a támadó az adatbázishoz.

Érintett verziók:

phpMyAdmin before 4.9.0 és minden korábbi verzió.

Megoldás: Frissítés újabb verzióra.

Elemzés leírás forrása: Egyéb referencia: www.securityfocus.com


Hatás

CVSS3 Severity and Metrics

Base score: 6.5 (Közepes)
Vector: AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Impact Score: 3.6
Exploitability Score: 2.8


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope (S): Unchanged
Confidentiality Impact (C): None
Integrity Impact (I): High
Availability Impact (A): None

CVSS2 Severity and Metrics

Base score: 4.3 (Közepes)
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Complexity (AC): Medium
Confidentiality Impact (C): None
Integrity Impact (S): Partial
Availability Impact (A):


Hivatkozások

CVE-2019-12616 - NVD CVE-2019-12616
https://nvd.nist.gov/vuln/detail/CVE-2019-12616
https://www.securityfocus.com/bid/108619/info