WordPress Payment Form for PayPal Pro plugin sérülékenység

CH azonosító: CH-14932
Cím: WordPress Payment Form for PayPal Pro plugin sérülékenység
Angol cím: WordPress Payment Form for PayPal Pro plugin vulnerability

Publikálás dátuma: 2020.07.03.
Utolsó módosítás dátuma: 2020.07.03.


Leírás

A CVE-2020-14092 számon a WordPress Payment Form for PayPal Pro pluginját érintő, magas kockázati besorolású  sérülékenység vált ismertté, amelyet kihasználva a támadó SQLi támadást indíthat.


Leírás forrása: Egyéb referencia: www.cybersecurity-help.cz
Leírás utolsó módosítása: 2020.07.03.


Elemzés leírás

A WordPress nyílt forráskódú, PHP-alapú tartalomkezelő és blog-rendszer, ami a MySQL adatbáziskezelőt használja adattárolásra. A WordPress weboldalkészítő pluginja a Payment Form for PayPal Pro, amely a PayPal Pro szolgáltatás integrálására szolgál.

A sérülékenység kihasználásához a távoli, jogosultsággal nem rendelkező támadónak egy speciálisan kialakított kérést kell küldeni az érintett adatbázisba. Sikeres végrehajtás esetén a támadó olvashatja, módosíthatja, törölheti az adatbázis tartalmát.

Érintett verziók:

  • WordPress Payment Form for PayPal Pro 1.2.48 előtti verziók

A gyártó honlapján közzétette a hibák javításait tartalmazó frissítéseket.


Elemzés leírás forrása: Egyéb referencia: www.cybersecurity-help.cz
Elemzés leírás utolsó módosítása: 2020.07.03.


Hatás

CVSS3 Súlyosság és Metrika

Alap pontszám: 8.5 (Magas)
Vektor: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Hatás pontszáma:
Kihasználhatóság pontszáma:


Támadás Vektora (AV): Hálózat
Támadás komplexitása (AC): Alacsony
Jogosultság Szükséges (PR): Nincs
Felhasználói Interakció (UI): Nincs
Hatókör (S): Nem változott
Bizalmasság Hatása (C): Magas
Sértetlenség Hatása (I): Magas
Rendelkezésre állás Hatása (A): Magas

CVSS2 Súlyosság és Metrika

Alap pontszám: (Nincs)
Vektor:
Hatás alpontszáma:
Kihasználhatóság alpontszáma:




Hivatkozások

Egyéb referencia: www.cybersecurity-help.cz
Egyéb referencia: wpvulndb.com
CVE-2020-14092 - NVD CVE-2020-14092