Apache Subversion sérülékenység

CH azonosító

CH-13743

Angol cím

Apache Subversion mod_dontdothat Module Exponential XML Entity Expansion Denial of Service Vulnerability

Felfedezés dátuma

2016.11.28.

Súlyosság

Közepes

Érintett rendszerek

Apache Software Foundation
Apache Subversion

Érintett verziók

1.4 (.0)
1.5 (.0)
1.6 (Base, .0, .1, .2, .3, .4, .5, .10, .15, .20, .21, .22, .23)
1.7 (Base, .0, .1, .2, .3, .4, .5, .10, .15, .18, .19, .20)
1.8 (Base, .0, .1, .2, .3, .4, .5, .6, .7, .8, .9, .10, .11, .12, .13, .14, .15, .16)
1.9 (.0, .1, .2, .3, .4)

Összefoglaló

Az Apache Subversion verziókezelő rendszer közepes kockázati besorolású sérülékenysége vált ismertté, amelyet kihasználva túlterheléses támadás indítható.

Leírás

A sérülékenységet az XML adatok helytelen feldolgozása okozza a Subversion mod_dontdothat moduljában. A támadó egy – saját maga által szerkesztett – kérés küldésével tudja kihasználni a sérülékenységet. Sikeres támadás esetén az XML feldolgozó a rendszer nagy mennyiségű erőforrásait használja el (processzor és memória), ami szolgáltatásmegtagadást (DoS) eredményez. Ahhoz, hogy a támadó ki tudja használni a sérülékenységet, hozzáféréssel kell rendelkeznie a rendszerhez (ez a feltétel csökkenti a sikeres támadások valószínűségét).

Megoldás

Frissítsen a legújabb verzióra: https://subversion.apache.org/download/#recommended-release