WordPress UnGallery plugin fájl felfedési sérülékenység

CH azonosító

CH-5426

Angol cím

WordPress UnGallery Plugin "pic", "zip", and "movie" File Disclosure Vulnerabilities

Felfedezés dátuma

2011.08.21.

Súlyosság

Közepes

Érintett rendszerek

UnGallery plugin
WordPress

Érintett verziók

WordPress UnGallery Plugin 1.x

Összefoglaló

A WordPress UnGallery plugin-jének sérülékenységei váltak ismertté, amelyeket kihasználva a támadók bizalmas információkat fedhetnek fel.

Leírás

  1. A source-php-ben a “zip” paraméter által átadott bemeneti adat nincs megfelelően ellenőrizve, mielőtt fájlok olvasásához használnák. Ez kihasználható tetszőleges lokális fájlok felfedésére.
    A sérülékenységet az 1.5.7 verzióban jelentették. Korábbi verziók is érintettek lehetnek.
  2. A source-php-ben a “movie” és a “pic” paraméterek által átadott bemeneti adatok nincsenek megfelelően ellenőrizve, mielőtt fájlok olvasásához használnák. Ez kihasználható tetszőleges lokális fájlok felfedésére.
    A sérülékenységet az 1.5.8 verzióban jelentették. Korábbi verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra