A Network Audio System több sebezhetősége

CH azonosító

CH-447

Felfedezés dátuma

2007.03.18.

Súlyosság

Alacsony

Érintett rendszerek

Network Audio System
Network Computing Devices

Érintett verziók

Network Computing Devices Network Audio System 1.x

Összefoglaló

A Network Audio System több olyan sebezhetőségét is jelentették, melyek jogosultság kiterjesztést vagy szolgáltatás megtagadást okozhatnak (DoS).

Leírás

A Network Audio System több olyan sebezhetőségét jelentették, melyeket rosszindulatú helyi felhasználók emelt jogosultság megszerzésére vagy szolgáltatás megtagadás okozására használhatnak fel.

  1. Az “accept_att_local()” határhibája a server/os/connection.c-ben felhasználható egy verem túlcsordulás előidézésére, melyet az az USL csatlakozások átlagosnál hosszabb (nagyobb mint 64 byte) kiszolgáló neve vált ki.
    A sikeres kiaknázás lehetővé teheti, hogy a rosszindulatú helyi felhasználók rendszergazda jogosultságot szerezzenek.
  2. Az “AddResource()” bemenet érvényesítési hibája a server/dia/resource.c-ben felhasználható a szolgáltatás összeomlásának előidézésére, melyet egy érvénytelen kliens azonosítót tartalmazó speciálisan e célból készült csomag vált ki.
  3. A “ProcAuWriteElement()” egész (integer) túlcsordulási hibája a server/dia/audispatch.c-ben a szolgáltatás összeomlásának előidézésére használható ki, melyet a speciálisan erre a célra készített csomag vált ki, ahol túl nagy a max_samples értéke.
  4. A “ProcAuSetElements()” határhibája a server/dia/audispatch.c-ben felhasználható a szolgáltatás összeomlásának előidézésére egy speciálisan erre a készült csomaggal, melyben túl nagyok a num_actions vagy numElements értékei.
  5. A “compileInputs()” input érvényesítési hibája a server/dia/auutil.c-ben felhasználható a szolgáltatás összeomlásának előidézésére egy erre a célra készített csomag hatására, ahol érvénytelen az elemek száma.
  6. Egy NULL-pointerre való hivatkozási hiba a párhuzamos csatlakozások feldolgozásában felhasználható a szolgáltatás összeomlásának előidézésére.

A sebezhetőségeket az 1.8a verzióban jelentették. Más verziók is lehetnek érintettek.

Megoldás

Javítva az SVN -ben.