A phpMyAdmin cross-site scripting sérülékenysége

CH azonosító

CH-1681

Felfedezés dátuma

2008.10.27.

Súlyosság

Alacsony

Érintett rendszerek

phpMyAdmin
phpMyAdmin Project

Érintett verziók

phpMyAdmin Project phpMyAdmin 2.x, 3.x

Összefoglaló

A phpMyAdmin sérülékenységét fedezték fel, melyet rosszindulatú támadók cross-site scripting támadásokra használhatnak.

Leírás

A phpMyAdmin sérülékenységét fedezték fel, melyet rosszindulatú támadók cross-site scripting támadásokra használhatnak.

A “db” paraméternek átadott bevitel a pmd_pdf.php-ben nincs megfelelően megtisztítva, mielőtt visszakerülne a felhasználóhoz. Ez kihasználható tetszőleges HTML és script kód végrehajtására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sikeres kiaknázás feltétele lehet az érvényes felhasználói jogosultság.

A sérülékenységet a 2.11.9.2 és a 3.0.1 verzióknál ismerték el, továbbá a 3.0.0 verzióban is jelentették. Más verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra