Adobe Acrobat/Reader többszörös sebezhetőség

CH azonosító

CH-1699

Felfedezés dátuma

2008.11.04.

Súlyosság

Magas

Érintett rendszerek

Acrobat
Adobe
Reader

Érintett verziók

Adobe Reader 8.x
Adobe Acrobat 8.x

Összefoglaló

Az Adobe Reader/Acrobat több sérülékenységét fedezték fel, amelyeket kihasználva rosszindulatú, helyi felhasználók emelt szintű jogosultságot szerezhetnek és támadók feltöhetik a felhasználók rendszerét.

Leírás

Az Adobe Reader/Acrobat több sérülékenységét fedezték fel, amelyeket kihasználva rosszindulatú, helyi felhasználók emelt szintű jogosultságot szerezhetnek és támadók feltöhetik a felhasználók rendszerét.

  1. Az “util.printf()” Javascript függvény egy határhibáját kihasználva a lebegőpontos formátum stringek vizsgálatakor, egy különlegesen kialakított PDF segítségével verem túlcsordulást lehet okozni, ami tetszőleges kód végrehajtását teszi lehetővé.
  2. Egy out-of-bounds tömb indexelési hibát kihasználva Type 1 beágyazott fontok vizsgálatakor, megváltoztatható a memória tartalma, ami tetszőleges kód végrehajtását teheti lehetővé.
  3. Egy HTTP hitelesítésehez használt AcrosJS függvény hibáját kihasnzálva, egy túl hosszú string átadásával megváltoztatható a memória tartalma, ami tetszőleges kód végrehajtását teheti lehetővé.
  4. Egy hibát kihasználva, egy Collab objektumot létrehozva és bizonyos sorrendben rajta műveleteket végrehajtva, megváltoztatható a memória tartalma, ami tetszőleges kód végrehajtását teheti lehetővé.
  5. Egy meghatározatlan hibát kihasználva szabálytalan felépítésű PDF objektumok vizsgálatakor, megváltoztatható a memória tartalma, ami tetszőleges kód végrehajtását teheti lehetővé.
  6. Az Adobe Reader letöltés kezelőjének bemenet érvényesítési hibáját kihasználva tetszőleges kód végrehajtása lehetséges.

    Az alábbi bejelentéssel van kapcsolatban:
    SA32546

  7. Az Adobe Reader letöltés kezelőjének egy hibáját kihasználva, a letöltés során megváltoztathatók a felhasználó internetes biztonsági beállításai.
  8. Egy JavaScript eljárás bemenet érvényesítési hibáját kihasználva tetszőleges kód végrehajtása lehetséges.
  9. Az UNIX/Linux verzió egy meghatározatlan hibáját kihasználva emelt szintű jogosultság szerezhető.

A sebezhetőségeket a 8.1.2. és azelőtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra