Apache Struts Jakarta sérülékenysége

CH azonosító

CH-13917

Angol cím

Apache Struts Jakarta vulnerability

Felfedezés dátuma

2017.03.08.

Súlyosság

Magas

Érintett rendszerek

Apache Software Foundation

Érintett verziók

Struts 2.3.5 - Struts 2.3.31
Struts 2.5 - Struts 2.5.10

Összefoglaló

Az Apache Struts Jakarta magas kockázati besorolású sérülékenysége vált ismertté, melyet kihasználva a támadó tetszőleges kódot futtathat a célrendszeren. A sérülékenységet kiküszöbölő megoldás már beszerezhető a gyártótól.

Leírás

A Jakarta multipart parszer sérülékenysége, egy fájlfeltöltés keretében, speciálisan megszerkesztett Content-Type küldésével használható ki, amelynek segítségével tetszőleges operációs rendszer parancs futtatható le a célrendszeren.

Megoldás

Frissítsen a legújabb verzióra

Megoldás

Frissítsen a 2.3.32, 2.5.10.1-es verzióra.

Hivatkozások

Gyártói referencia: cwiki.apache.org
Egyéb referencia: www.checkpoint.com
CVE-2017-5638 - NVD CVE-2017-5638