Apache Tomcat sérülékenységei

CH azonosító

CH-14237

Angol cím

Apache Tomcat vulnerabilities

Felfedezés dátuma

2017.09.19.

Súlyosság

Magas

Érintett rendszerek

Apache Software Foundation
Tomcat

Érintett verziók

Tomcat Java Server 7.0

Összefoglaló

Az Apache Tomcat egy magas és egy közepes kockázati besorolású sérülékenysége vált ismertté, amelyek a legújabb biztonsági frissítéssel kiküszöbölhetők.

Leírás

Egy nem hitelesített, távoli felhasználó egy speciálisan kialakított HTTP PUT kérést tartalmazó tetszőleges JSP (Java Server Page) fájlt tölthet fel a célrendszerre, amivel lehetősége nyílik tetszőleges kódok futtatására. A kód a célszolgáltatás jogosultságaival fog futni. [CVE-2017-12615]

Egy nem hitelesített támadó egy speciálisan kialakított kéréssel megtekintheti a JSP forráskódját a VirtualDirContext szolgáltatást futtató célrendszereken. Ezáltal potenciálisan érzékeny információkhoz férhet hozzá. [CVE-2017-12616]

Megoldás

Frissítsen a legújabb verzióra

Megoldás

Frissítse a Tomcat-et a 7.0.81-es verzióra.