Apple Mac OS X slpd puffer túlcsordulásos sebezhetőség

CH azonosító

CH-344

Felfedezés dátuma

2007.01.18.

Súlyosság

Magas

Érintett rendszerek

Apple
Mac OS X

Érintett verziók

Apple Mac OS X

Összefoglaló

Az Apple Mac OS X egy olyan sebezhetőségét azonosították, melyet a támadók szolgáltatás megtagadás okozására vagy tetszőleges parancsok lefuttatására használhatnak fel.

Leírás

Az Apple Mac OS X egy olyan sebezhetőségét azonosították, melyet kihasználva rosszindulatú helyi felhasználók, és valószínűleg támadók, szolgáltatás megtagadást okozhatnak és emelt szintű jogosultságot szerezhetnek.

A sebezhetőséget az SLP daemon (“slpd”) egy határhibája okozza egy regisztrációs kérelem “attr-list” mezőjének feldolgozásakor. Ezt kihasználva puffer túlcsordulás okozható, ami a szolgáltatás összeomlásához vagy tetszőleges kód emelt szintű jogosultsággal történő végrehajtásához vezethet.

A sebezhetőséget a Mac OS X 10.4.8. (8L2127) verziójában, x86 platformon jelentették. Más kiadások is lehetnek érintettek.

Megoldás

Telepítse a javítócsomagokat