Asterisk sérülékenységek

CH azonosító

CH-6755

Angol cím

Asterisk Multiple Vulnerabilities

Felfedezés dátuma

2012.04.23.

Súlyosság

Közepes

Érintett rendszerek

Asterisk
Asterisk Business Edition
Digium

Érintett verziók

Asterisk 1.x
Asterisk 10.x
Asterisk Business Edition 3.x

Összefoglaló

Az Asterisk és Asterisk Business Edition olyan sérülékenységei váltak ismertté, amelyeket kihasználva rosszindulatú felhasználók szolgáltatás megtagadást (DoS – Denial of Service) tudnak előidézni, megkerülhetnek bizonyos biztonsági szabályokat és feltörhetik a sérülékeny rendszert.

Leírás

  1. Az Asterisk Manager Interface egy hibája, mely a MixMonitor alkalmazás “originates” műveletek kezelésekor vagy a “SHELL” és “EVAL” függvényekkel való “GetVar” vagy “Status” kezelő műveleteknél jelentkezik, nem korlátozza megfelelően a hozzáférést és kihasználható tetszőleges shell parancsok futtatására.

    Ezt a sérülékenységet az Asterisk 1.6.2.24 előtti 1.6.2.x -es, 1.8.11.1 előtti 1.8.x -es és az 10.3.1 előtti 10.x -es, illetve az Asterisk Business Edition 3.7.4 előtti 3.x -es verziókban jelentették.

  2. Egy határhiba a Skinny channel driver-ben KEYPAD_BUTTON_MESSAGE események kezelésekor kihasználható halom-alapú puffer túlcsordulás előidézésére speciálisan erre a célra elkészített KEYPAD_BUTTON_MESSAGE események használatával.

    A sérülékenység kihasználása tetszőleges kód futtatását teszi lehetővé.

    Ezt a sérülékenységet az Asterisk 1.6.2.24 előtti 1.6.2.x -es, 1.8.11.1 előtti 1.8.x -es és az 10.3.1 előtti 10.x -es verziókban jelentették be.

  3. Egy SIP channel driver hiba kihasználható program összeomlás előidézésére speciálisan erre a célra elkészített SIP UPDATE kérések használatával.

    A sérülékenység sikeres kihasználásának feltétele, hogy a „trustrpid” beállítás értéke „True” legyen.

    Ezt a sérülékenységet az Asterisk 1.8.11.1 előtti 1.8.x -es és az 10.3.1 előtti 10.x -es, illetve az Asterisk Business Edition 3.7.4 előtti 3.x -es verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra