Az nginx “ngx_http_parse_complex_uri()” sérülékenysége

CH azonosító

CH-2487

Felfedezés dátuma

2009.09.14.

Súlyosság

Magas

Érintett rendszerek

N/A
nginx

Érintett verziók

N/A nginx 0.1.0 - 0.5.37, 0.6.0 - 0.6.38, 0.7.0 - 0.7.61, 0.8.0 - 0.8.14

Összefoglaló

Az nginx egy sérülékenységet fedezték fel, amit kihasználva támadók szolgáltatás megtagadást idézhetnek elő, vagy feltörhetik a sérülékeny rendszert.

Leírás

Az nginx egy sérülékenységet fedezték fel, amit kihasználva támadók szolgáltatás megtagadást idézhetnek elő, vagy feltörhetik a sérülékeny rendszert.

A sérülékenységet az “ngx_http_parse_complex_uri()” függvény, az URL-ek feldolgozásakor jelentkező hibája okozza. Ezt kihasználva puffer alulcsordulást lehet előidézni és tetszőleges kódot lehet futtatni speciálisan elkészített csomagok segítségével.

Megoldás

Frissítsen a legújabb verzióra