bcfg2 Trigger bővítmény parancs befecskendezéses sérülékenység

CH azonosító

CH-7120

Angol cím

bcfg2 Trigger Plugin Command Injection Vulnerability

Felfedezés dátuma

2012.06.28.

Súlyosság

Közepes

Érintett rendszerek

Bcfg2
N/A

Érintett verziók

bcfg2 1.x

Összefoglaló

A bcfg2 sérülékenysége vált ismertté, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenység a Trigger plugin-ben lévő bemeneti adat megtisztítási hibából adódik, ami a klienstől érkező UUID mező használatakor jelentkezik. Ez kihasználható tetszőleges shell parancsok befecskendezésére és futtatására a szerver démon (tipikusan root) jogosultságaival.

A sérülékenység sikeres kihasználása root hozzáférést igényel a kliens rendszeren.

A sérülékenységet az 1.2.x verzióban jelentették.

Megoldás

Frissítsen a legújabb verzióra