Celery argumentum feldolgozás jogosultság kiterjesztéses sérülékenység

CH azonosító

CH-6008

Angol cím

Celery Argument Processing Privilege Escalation Security Issue

Felfedezés dátuma

2011.11.27.

Súlyosság

Alacsony

Érintett rendszerek

Celery
N/A

Érintett verziók

Celery 2.x

Összefoglaló

A Celery egy sérülékenysége vált ismertté, amelyet kihasználva rosszindulatú, helyi felhasználók bizonyos műveleteket kiterjesztett jogosultsággal hajthatnak végre.

Leírás

A sérülékenységet a démon processznek átadott bizonyos argumentumok feldolgozása közben jelentkező hiba okozza, aminek következtében bizonyos fájlok nem megfelelő jogosultságokkal jönnek létre. Ez kihasználható üzenetek küldésére vagy kiterjesztett jogosultsággal történő kódfuttatásra.

A sérülékenység a 2.4.4 előtti verziókat érinti.

Megoldás

Frissítsen a 2.4.4 verzióra.