Cisco Secure ACS többszörös sérülékenység

CH azonosító

CH-328

Felfedezés dátuma

2007.01.09.

Súlyosság

Magas

Érintett rendszerek

CISCO
Secure ACS
Secure ACS Solution Engine

Érintett verziók

CISCO Secure ACS Solution Engine 3.x
CISCO Secure ACS 3.x, 4.x

Összefoglaló

Számos sérülékenységet jelentettek a Cisco Secure ACS-ben, amiket rosszindulatú támadók kihasználhatnak szolgáltatás megtagadásos támadáshoz, és az érintett rendszerek feltöréséhez.

Leírás

Számos sérülékenységet jelentettek a Cisco Secure ACS-ben, amiket rosszindulatú támadók kihasználhatnak szolgáltatás megtagadásos támadáshoz, és az érintett rendszerek feltöréséhez.

  1. Egy nem meghatározott hiba a CSAdmin szolgáltatásban a HTTP GET lekérdezések kezelése során kihasználható verem puffer túlcsordulás okozására egy különlegesen kialakított HTTP GET lekérdezéssel.
  2. Egy nem meghatározott hiba van a CSRadius szolgáltatásban. A RADIUS Accounting-Request csomagok feldolgozásakor a különlegesen kialakított csomagok puffer túlcsordulást okozhatnak.
  3. A sérülékenységek sikeres kiaknázása lehetővé teszi tetszőleges kód futtatását.

  4. Egy nem meghatározott hiba van a CSRadius szolgáltatásban. A RADIUS Access-Request csomagok feldolgozásakor különlegesen kialakított csomagok a szolgáltatás összeomlásához vezethetnek.

A sérülékenységeket a 4.1. előtti verziókban jelentették, de más verziók is érintettek lehetnek.

Megjegyzés: Az alábbi termékek nem érintettek:
Cisco Secure ACS for Unix (CSU)
Cisco CNS Access Registrar (CAR)
Cisco Secure ACS server Windows 4.1(X) és későbbi verziók alatt
Cisco Secure ACS server solution Engine 4.1(X) és későbbi verziók.

Megoldás

Frissítsen a legújabb verzióra