cURL / libcURL puffer túlcsordulásos sérülékenység

CH azonosító

CH-8422

Angol cím

cURL / libcURL "Curl_sasl_create_digest_md5_message()" Buffer Overflow Vulnerability

Felfedezés dátuma

2013.02.06.

Súlyosság

Magas

Érintett rendszerek

Haxx
cURL

Érintett verziók

cURL 7.x

Összefoglaló

A cURL / libcURL egy sérülékenységét jelentették, amit kihasználva a támadók feltörhetik a felhasználó rendszerét.

Leírás

A sérülékenységet a “Curl_sasl_create_digest_md5_message()” függvény (lib/curl_sasl.c) egy határhibája okozza, amely a SASL DIGEST.MD5 hitelesítés feldolgozása során keletkezik, és amit kihasználva verem alapú puffer túlcsordulást lehet előidézni.

A sérülékenység sikeres kihasználása tetszőleges kód végrehajtását teszi lehetővé, de ehhez szükséges, hogy a felhasználó kapcsolódjon egy rosszindulatú szerverhez.

A sérülékenységet a 7.26.0 és 7.28.1 közti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra