D-Link termékek SSH szerver puffer túlcsordulás sérülékenysége

CH azonosító

CH-5855

Angol cím

D-Link Products SSH Server Buffer Overflow Vulnerability

Felfedezés dátuma

2011.10.27.

Súlyosság

Magas

Érintett rendszerek

D-Link
DES-3800 series
DWL-2100AP
DWL-3200AP

Érintett verziók

D-Link DES-3800 series
D-Link DWL-2100AP
D-Link DWL-3200AP

Összefoglaló

Több D-Link termék olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak a sérülékeny eszköz feltörésére.

Leírás

A sérülékenységet a Secure Shell (SSH) szerverben található nem részletezett hiba okozza, amely kihasználható puffer túlcsordulás okozására.

A sérülékenység sikeres kihasználása tetszőleges kód futtatását teszi lehetővé.

A sérülékenységet az alábbi firmware verziókban ismerték fel:

  • D-Link DES-3800 series R4.50B052 előtti verziók
  • D-Link DWL-2100AP 2.50RC548 előtti verziók
  • D-Link DWL-3200AP 2.55RC549 előtti verziók

Megoldás

Frissítsen a legújabb verzióra