Drupal Apache Solr Autocomplete bővítmény script beszúrásos sérülékenység

CH azonosító

CH-7482

Angol cím

Drupal Apache Solr Autocomplete Module Script Insertion Vulnerability

Felfedezés dátuma

2012.08.29.

Súlyosság

Alacsony

Érintett rendszerek

Apache Solr Autocomplete Module
Drupal

Érintett verziók

Drupal Apache Solr Autocomplete Module 6.x, 7.x

Összefoglaló

A Drupal Apache Solr Autocomplete egy sérülékenységét jelentették, amit kihasználva a támadók script beszúrásos (script insertion) támadásokat hajthatnak végre.

Leírás

Az automatikus kiegészítés eredményén keresztül átadott bemeneti adat nem megfelelően van megtisztítva, mielőtt a felhasználó számára megjelenítésre kerül. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységet a 6.x-1.4 előtti 6.x-1.x és a 7.x-1.3 előtti 7.x-1.x verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra