Drupal Glossary modul sérülékenység

CH azonosító

CH-6831

Angol cím

Drupal Glossary Module Taxonomy Information Script Insertion Vulnerability

Felfedezés dátuma

2012.05.09.

Súlyosság

Alacsony

Érintett rendszerek

Drupal
Glossary Module

Érintett verziók

Drupal Glossary modul 6.x

Összefoglaló

A Drupal Glossary modul olyan sérülékenysége vált ismertté, amelyet a rosszindulatú felhasználók kihasználhatnak script beszúrásos (script insertion) támadások indítására.

Leírás

Egyes taxonomy információk segítségével átadott bizonyos bemenet nem kerül megfelelően megtisztításra, mielőtt felhasználásra kerülne. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenység kihasználásához a taxonomy szabályok létrehozásához és szerkesztéséhez való jogosultság szükséges.

A sérülékenységet a 6.x-1.8 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra