Drupal MailChimp bővítmény script beszúrásos sérülékenység

CH azonosító

CH-7846

Angol cím

Drupal MailChimp Module Script Insertion Vulnerability

Felfedezés dátuma

2012.10.25.

Súlyosság

Közepes

Érintett rendszerek

Drupal
MailChimp Module

Érintett verziók

Drupal MailChimp Module 7.x

Összefoglaló

A Drupal MailChimp bővítmény sérülékenysége vált ismertté, amelyet kihasználva a támadók script beszúrásos (script insertion) támadásokat hajthatnak végre.

Leírás

A webhook típusnak átadott bizonyos bemeneti adat nincs megfelelően megtisztítva, mielőtt a watchdog-ban feljegyzésre kerülne. Ez kihasználható tetszőleges HTML és script kód beszúrására, amely a felhasználó böngészőjének munkamenetében fog lefutni az érintett oldallal kapcsolatban, a káros tartalom megtekintése közben.

A sérülékenység a 7.x-2.7 előtti 7.x-2.x verziókat érinti.

Megoldás

Frissítsen a legújabb verzióra