Drupal Panels modul script beszúrás sérülékenység

CH azonosító

CH-4187

Angol cím

Drupal Panels Module Script Insertion Vulnerability

Felfedezés dátuma

2011.01.12.

Súlyosság

Alacsony

Érintett rendszerek

Drupal
Panels module

Érintett verziók

Drupal Panels Module 6.x 3.0 - 3.8

Összefoglaló

A Drupal Panels modul olyan sérülékenysége vált ismertté, amelyet kihasználva rosszindulatú felhasználók script beszúrásos támadásokat hajthatnak végre.

Leírás

Bizonyos beazonosítatlan bemenet nincs megfelelően ellenőrizve mielőtt felhasználnák. Ez kihasználható tetszőleges HTML és script kód beszúrására, amely a felhasználó böngésző munkamenetében kerül lefuttatásra, a rosszindulatú tartalom megtekintésekor.

A sérülékenység sikeres kihasználásához “administer advanced pane settings” jogosultság szülséges, valamint legalább egy jogosultság, amely lehetővé teszi a panelok létrehozását vagy szerkesztését (pl.: “use page manager”, “administer mini panels” vagy “create panel nodes”).

Megoldás

Frissítsen a legújabb verzióra