Drupal sérülékenységei

CH azonosító

CH-14114

Angol cím

Drupal vulnerabilities

Felfedezés dátuma

2017.06.20.

Súlyosság

Kritikus

Érintett rendszerek

Drupal

Érintett verziók

Drupal 7.56 előtti
Drupal 8.3.4 előtti

Összefoglaló

A Drupal több sérülékenysége vált ismertté, amelyeket kihasználva tetszőleges kód futtatható a rendszeren, illetve hozzáférés szerezhető bizonyos fájlokhoz.

Leírás

A Drupal 7-es és 8-as verzióiban fedeztek fel több hibát: a PECL YAML értelmező nem kezeli megfelelően a PHP objektumokat a Drupal Core bizonyos műveletei során, amely távoli kódfuttatásra ad lehetőséget. A névtelen felhasználói fiókkal feltöltött fájlok más anonymous felhasználók számára is hozzáférhetővé válnak.

Megoldás

Frissítsen a legújabb verzióra

Megoldás

Frissítsen a Drupal 7.56, illetve a 8.3.4 verzióra.