Drupal Views bővítmény beszúrásos sérülékenységek

CH azonosító

CH-8774

Angol cím

Drupal Views Module View Configuration Fields Script Insertion Vulnerabilities

Felfedezés dátuma

2013.03.21.

Súlyosság

Alacsony

Érintett rendszerek

Drupal
Views module

Érintett verziók

Drupal Views Module 7.x

Összefoglaló

A Drupal Views bővítmény olyan sérülékenységei váltak ismertté, amelyeket a rosszindulatú felhasználók kihasználhatnak script beszúrásos (script insertion) támadások kezdeményezésére.

Leírás

Bizonyos nézet konfigurációs mezőkkel kapcsolatos bemeneti adat nincs megfelelően megtisztítva mielőtt felhasználásra kerülne. Ezt kihasználva tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenység “Administer vocabularies and terms” jogosultságokkal vagy további Views-zal integrálódó járulékos modulok adminisztrátor jellegű jogosultságaival használható ki.

A sérülékenységeket a 7.x-3.6 előtti verziókban ismerték fel.

Megoldás

Frissítsen a legújabb verzióra