e107 Hupsi Fancybox Plugin tetszőleges fájl feltöltési sérülékenység

CH azonosító

CH-7071

Angol cím

e107 Hupsi Fancybox Plugin Arbitrary File Upload Vulnerability

Felfedezés dátuma

2012.06.19.

Súlyosság

Magas

Érintett rendszerek

N/A
e107

Érintett verziók

Hupsi Fancybox 1.x (plugin for e107)

Összefoglaló

Az e107 Hupsi Fancybox bővítményének olyan sérülékenységét fedezték fel, amelyet a támadók kihasználhatnak a sérülékeny rendszer feltörésére.

Leírás

A sérülékenységet az okozza, hogy az e107_plugins/hupsi_fancybox/uploader/uploadify.php script lehetővé teszi tetszőleges kiterjesztésű fájl feltöltését a webroot egyik belső mappájába. Ez kihasználható tetszőleges PHP kód futtatására, egy rosszindulatú PHP script feltöltésével.

A sérülékenységet az 1.4 verzióban igazolták, de más kiadások is érintettek lehetnek.

Megoldás

Korlátozza az e107_plugins/hupsi_fancybox/uploader/uploadify.php script-hez való hozzáférést (például .htaccess használatávall)!