Empire Server puffer túlcsordulásos sérülékenységek

CH azonosító

CH-7296

Angol cím

Empire Server Multiple Buffer Overflow Vulnerabilities

Felfedezés dátuma

2012.07.29.

Súlyosság

Magas

Érintett rendszerek

N/A
Wolfpack Empire Server

Érintett verziók

Empire Server 4.x

Összefoglaló

Az Empire Server olyan sérülékenységei váltak ismertté, amelyeket a támadók kihasználhatnak a sérülékeny rendszer feltörésére.

Leírás

A sérülékenységeket a “build”, “scrap” és “scuttle” parancsok kezelésekor jelentkező határhibák okozzák és a parancs bemenetnek átadott túlságosan hosszú stringgel kihasználhatóak verem alapú puffer túlcsordulás előidézésére.

A sérülékenységek sikeres kihasználása tetszőleges kód futtatását teszik lehetővé.

A sérülékenységeket a 4.3.30 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra