Firefox Yoono bővítmény cross-context scripting sérülékenység

CH azonosító

CH-2678

Felfedezés dátuma

2009.11.24.

Súlyosság

Közepes

Érintett rendszerek

Firefox Yoono
Mozilla

Érintett verziók

Mozilla Firefox Yoono 5.x, 6.x

Összefoglaló

A Firefoxhoz készült Yoono bővítmény olyan sérülékenysége vált ismertté, melyet kihasználva támadók föltörhetik a felhasználó rendszerét.

Leírás

A Firefoxhoz készült Yoono bővítmény olyan sérülékenysége vált ismertté, melyet kihasználva támadók föltörhetik a felhasználó rendszerét.

A sérülékenységet az okozza, hogy a DOM esemény kezelők a “chrome:” kontextusában kerülnek kiértékelésre. Ez kihasználható tetszőleges parancs futtatására a felhasználó rendszerén, amikor az meghívja a bővítményt egy speciálisan szerkesztett weboldalon.

A sérülékenység a 6.1.1-es verzióban található, egyéb verziók is érintettek lehetnek.

Megoldás

Kizárólag megbízható weboldalakon használja a bővítményt!