GLPI SQL befecskendezéses és PHP kódfuttatási sérülékenység

CH azonosító

CH-9788

Angol cím

GLPI SQL Injection and PHP Code Execution Vulnerabilities

Felfedezés dátuma

2013.09.18.

Súlyosság

Közepes

Érintett rendszerek

PHP
PHP Group

Érintett verziók

GLPI 0.x

Összefoglaló

Két sebezhetőséget fedeztek fel a GLPI rendszerében.

Leírás

Két sebezhetőséget fedeztek fel a GLPI rendszerében, amelyet kihasználva a támadók SQL befecskendezéses támadásokat hajhatnak végre és feltörhetik a sérülékeny rendszert.

Referencia HTTP fejléccel  az install/ install.php részére átadott bemeneti adat (amikor az install” értéke “Etape_4) nincs megfelelően ellenőrizve mielőtt megtörténne egy SQL lekérdezés. Ez kihasználható az SQL lekérdezések módosítására tetszőleges SQL kód befecskendezésével.

Több POST paraméterrel az install/ install.php részére átadott bemeneti adat (amikor az install” értéke “update_1)nincs megfelelően ellenőrizve mielőtt tárolja a config/config_db.php konfigurációs fájlba. Ez kihasználható tetszőleges PHP kód futtatására.

A sérülékenységeket a 0.84.1 verzióban fedezték fel, de a korábbi verziók is érintettek lehetnek.

Megoldás

Frissítse a 0.84.2-es változatra.