GNOME Glib PCRE pcre_compile.c puffer túlcsordulásos sérülékenysége

CH azonosító

CH-1374

Felfedezés dátuma

2008.07.05.

Súlyosság

Közepes

Érintett rendszerek

GNOME
Glib

Érintett verziók

GNOME Glib 2.x

Összefoglaló

A GNOME Glib olyan sérülékenysége vált ismertté, melyet kihasználva rosszindulatú támadók szolgáltatás megtagadást tudnak előidézni és föltörhetik a könyvtárat használó alkalmazást.

Leírás

A GNOME Glib olyan sérülékenysége vált ismertté, melyet kihasználva rosszindulatú támadók szolgáltatás megtagadást tudnak előidézni és föltörthetik a könyvtárat használó alkalmazást.

A sérülékenységet a PCRE könyvtár egy sérülékeny kódjának használata okozza.

A sérülékenység a 2.16.4-est megelőző verziókban található.

Megoldás

Frissítsen a legújabb verzióra