Gnome Subtitles LD_LIBRARY_PATH biztonsági hibája

CH azonosító

CH-3799

Angol cím

Gnome Subtitles LD_LIBRARY_PATH Security Issue

Felfedezés dátuma

2010.10.14.

Súlyosság

Alacsony

Érintett rendszerek

GNOME
Subtitles

Érintett verziók

Gnome Subtitles 1.x

Összefoglaló

A Gnome Subtitles biztonsági problémáját jelentették, amit a támadók kihasználhatnak a felhasználói rendszerek feltörésére.

Leírás

A biztonsági hibát az okozza, hogy a gnome-subtitles script a LD_LIBRARY_PATH környezeti változót nem megbízhatóan állítja be. Ez kihasználható tetszőleges kód lefuttatására, ha a felhasználó a scriptet egy káros könyvtárat tartalmazó mappában futtatja le.

A hibát az 1.0 verzióban jelentették.

Megoldás

Frissítsen a legújabb verzióra