GNU Emacs sérülékenység

CH azonosító

CH-7370

Angol cím

GNU Emacs "enable-local-variables" Variable Processing Vulnerability

Felfedezés dátuma

2012.08.12.

Súlyosság

Közepes

Érintett rendszerek

Emacs
GNU Project

Érintett verziók

GNU Emacs 23.x, 24.x

Összefoglaló

A GNU Emacs egy sérülékenységét jelentették, amit kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenység az “enable-local-variables” változó file-local változó részlegének feldolgozása közben lép fel. Ezt kihasználva az “eval” form kiértékelésekor tetszőleges Lisp kódot lehet végrehajtani.

A hiba sikeres kihasználásához szükséges, hogy az “enable-local-variables” “:safe” értékre legyen állítva.

A sérülékenységet a 23.2, 23.3, 23.4 és 24.1 verziókban jelentették.

Megoldás

Telepítse a javítócsomagokat