GNU patch könyvtár bejárás sérülékenység

CH azonosító

CH-4518

Angol cím

GNU patch Directory Traversal Vulnerability

Felfedezés dátuma

2011.03.08.

Súlyosság

Alacsony

Érintett rendszerek

GNU Project
patch

Érintett verziók

GNU patch 2.x

Összefoglaló

A GNU patch olyan sérülékenységét jelentették, melyet a támadók kihasználhatnak bizonyos adatok megváltoztatására vagy a sérülékeny rendszer feltörésére.

Leírás

A sérülékenységet az okozza. hogy az alkalmazás nem megfelelően kezeli a javító csomagokban az útvonalakat. Ez kihasználható a tervezett cél könyvtáron kívüli tetszőleges fájl módosítására.

A sérülékenység kapcsolatos a Debian dpkg hibájával. A dpkg-source komponens nem megfelelően kezeli a javító csomagokban az útvonalakat “3.0 quilt” verziójú forrás csomagok kitömörítésekor.

Megoldás

Javítva a fejlesztői verzióban.