GnuPG OpenPGP üzenet titkosítás feloldása közbeni sebezhetősége

CH azonosító

CH-264

Felfedezés dátuma

2006.12.07.

Súlyosság

Magas

Érintett rendszerek

GNU Project
GnuPG (gpg)

Érintett verziók

GNU Project GnuPG (gpg) 1.0.0 - 1.4.6, 1.9.0 - 1.9.95, 2.0.0 - 2.0.2

Összefoglaló

Egy olyan sebezhetőséget azonosítottak a GnuPG-ben, melyet a távoli támadók felhasználhatnak a sérült server feltörésére és tetszőleges parancsok lefuttatására.

Leírás

A GnuPG olyan sebezhetőségét jelentették, melyet támadók a sérült rendszer feltörésére használhattak fel.

A sebezhetőség a rosszul formázott OpenPGP üzenetek titkosításának feloldásakor lép fel. Ezt kihasználva megváltoztatható a memória tartalma, amikor a speciálisan elkészített OpenPGP üzenet titkosítása feloldásra kerül.

A sikeres kiaknázás lehetővé teszi tetszőleges kód lefuttatását.

Megoldás

Telepítse a javítócsomagokat