HP-UX-on futó Apache vagy Tomcat PHP sérülékenysége

CH azonosító

CH-1305

Felfedezés dátuma

2008.06.10.

Súlyosság

Magas

Érintett rendszerek

HP-UX
Hewlett Packard (HP)
PHP
PHP Group

Érintett verziók

Hewlett Packard (HP) HP-UX B.11.11, B.11.23, B.11.31
PHP Group PHP 5.2.0 - 5.2.5

Összefoglaló

Egy lehetséges biztonsági sérülékenységet azonosítottak a HP-UX-on futó Apache vagy Tomcat szervereken, melyeken PHP fut. Ez távolról kihasználható tetszőleges kód futtatására.

Leírás

Egy lehetséges biztonsági sérülékenységet azonosítottak a HP-UX-on futó Apache vagy Tomcat szervereken, melyeken PHP fut. Ez távolról kihasználható tetszőleges kód futtatására.

A PHP-ben, az elérési út olvasásának hibája miatt, a fájlnevek feldolgozásakor fellépő hibát kihasználva egy távoli támadó tetszőleges kódot futtathat az érintett rendszeren.

Megoldás

Megjegyzés: Apache 2.19 vagy újabb tartalmazza a PHP 5.2.6 vagy újabb változatát. Tomcat v5.5.23.01 vagy újabb tartalmazza a PHP v5.2.6 vagy újabb változatát.

A frissítések elérhetőek és letölthetőek az alábbi helyről: