Html-edit CMS cross-site scripting és SQL befecskendezéses sérülékenységei

CH azonosító

CH-4125

Angol cím

Html-edit CMS Cross-Site Scripting and SQL Injection Vulnerabilities

Felfedezés dátuma

2010.12.20.

Súlyosság

Közepes

Érintett rendszerek

Html-edit CMS
N/A

Érintett verziók

Html-edit CMS 3.x

Összefoglaló

A Html-edit CMS olyan sérülékenységeit jelentették, amelyeket a támadók kihasználva cross-site scripting (CSS/XSS) és SQL befecskendezéses (SQL injection) támadásokat hajthatnak végre.

Leírás

  1. Az index.php-ben található “nuser” paraméter által átadott bemeneti adat (ha a “pageid” beállítás “ext”-re, “ext” beállítás “login”-re és “extpage” beállítás “registrate”-re van állítva) nincs megfelelően ellenőrizve, mielőtt SQL lekérdezésekben felhasználásra kerülne. Ez kihasználható SQL lekérdezések manipulálására, tetszőleges SQL kódok befecskendezésével.
  2. Az index.php-ben található “error” paraméter által átadott bemeneti adat az extensions/login/frontend/index.php-nek nincs megfelelően ellenőrizve, a felhasználónak történő visszaadás előtt. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységeket a 3.1.8 verzióban jelentették. Más verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében

Hivatkozások

SECUNIA 42664
Gyártói referencia: www.htbridge.ch
Gyártói referencia: www.htbridge.ch


Legfrissebb sérülékenységek
CVE-2022-44580 – RichPlugins Plugin For Google Reviews for WordPress sérülékenysége
CVE-2023-23421 – Microsoft Windows sérülékenysége
CVE-2023-23422 – Microsoft Windows sérülékenysége
CVE-2023-23420 – Microsoft Windows sérülékenysége
CVE-2023-23423 – Microsoft Windows sérülékenysége
CVE-2022-39214 – Combodo iTop (aka IT Operations Portal) sérülékenysége
CVE-2022-39216 – Combodo iTop (aka IT Operations Portal), Combodo iTop (aka IT Operations Portal) Community Edition sérülékenysége
CVE-2023-27501 – sap / netweaver application server abap, SAP NetWeaver Application Server ABAP sérülékenysége
CVE-2023-26360 – Adobe ColdFusion Improper Access Control sérülékenysége
CVE-2023-23397 – Microsoft Office Outlook sérülékenysége
Tovább a sérülékenységekhez »