IBM AIX “getpwnam()” LDAP szűrés jogosultság kiterjesztés sérülékenység

CH azonosító

CH-6796

Angol cím

IBM AIX "getpwnam()" LDAP Filtering Privilege Escalation Vulnerability

Felfedezés dátuma

2012.05.03.

Súlyosság

Alacsony

Érintett rendszerek

AIX
IBM

Érintett verziók

AIX 5.x
AIX 6.x
AIX 7.x

Összefoglaló

Az IBM AIX olyan sérülékenységét jelentették, amelyet rosszindulatú helyi felhasználók kihasználva emelt szintű jogosultságokat szerezhetnek.

Leírás

A sérülékenységet az LDAP hitelesítésen belüli “getpwnam()” függvény okozza, amely kihasználható további jogosultságok megszerzésére.

A sérülékenység sikeres kihasználásához szükséges a kiterjesztett LDAP felhasználói szűrés konfigurálása.

A sérülékenységet az 5.3, 6.1 és 7.1 verziókban jelentették.

Megoldás

Telepítse a javítócsomagokat

Hivatkozások

SECUNIA 49073
CVE-2012-0745 - NVD CVE-2012-0745
Gyártói referencia: aix.software.ibm.com