IBM Netezza WebAdmin sérülékenységek

CH azonosító

CH-8416

Angol cím

IBM Netezza WebAdmin Multiple Vulnerabilities

Felfedezés dátuma

2013.02.07.

Súlyosság

Alacsony

Érintett rendszerek

IBM
Netezza

Érintett verziók

IBM Netezza 6.x, 7.x

Összefoglaló

Az IBM Netezza  sérülékenységei váltak ismertté, amelyeket kihasználva rosszindulatú felhasználók módosíthatnak bizonyos adatokat, script beszúrásos (script insertion) és SQL befecskendezéses (SQL injection) támadásokat hajthatnak végre, támadók pedig hamisításos (spoofing) támadásokat követhetnek el.

Leírás

  1. Egyes nem részletezett bemeneti adatok nincsenek megfelelően megtisztítva az SQL lekérdezésekben történő használat előtt. Ez kihasználható az SQL lekérdezések módosítására tetszőleges SQL kód befecskendezésével.
  2. Egyes nem részletezett bemeneti adatok nincsenek megfelelően megtisztítva használat előtt. Ez kihasználható tetszőleges HTML és script kód futtatására, ami a felhasználó böngészőjének munkamenetében fut le egy érintett oldallal kapcsolatosan a kártékony adatok megtekintésekor.
  3. A kérések azonosításának ellenőrzésekor keletkező hiba kihasználható bizonyos adatok módosítására.
  4. Egyes nem részletezett bemeneti adatok nincsenek megfelelően ellenőrizve használat előtt. Ez kihasználható tetszőleges weboldal megjelenítésére, többek között ha a felhasználó rákattint egy megbízható domain-en hostolt érintett scriptre mutató speciálisan erre a célra elkészített linkre.

A sérülékenységek a  6.0.5, 6.0.8 és 7.0 verzióban találhatók.

Megoldás

Telepítse a javítócsomagokat