IBM WebSphere Application Server Community Edition Tomcat miatti sérülékenysége

CH azonosító

CH-3708

Angol cím

IBM WebSphere Application Server Community Edition Tomcat Vulnerability

Felfedezés dátuma

2010.09.29.

Súlyosság

Közepes

Érintett rendszerek

IBM
WebSphere Application Server Community Edition

Érintett verziók

IBM WebSphere Application Server Community Edition 2.x

Összefoglaló

Az IBM ismertette az IBM WebSphere Application Server Community Edition sérülékenységét, melyet a támadók kihasználhatnak egyes rendszer információk felfedésére és szolgáltatás megtagadás (DoS – Denial of Service) okozásra.

Leírás

Az alkalmazás hibái az Apache Tomcat sérülékeny verziójával vannak összefüggésben.

A Tomcat sérülékenységét az okozza, hogy nem jól kezeli a speciális “Transfer-Encoding” fejléccel rendelkező HTTP kéréseket. Ez kihasználható érzékeny információk megszerzésére, vagy speciálisan elkészített HTTP kérések elküldésével megakadályozható az utána következő kérések helyes kezelése.

A sérülékenységet az AIX, Linux, Solaris és Windows rendszeren futó 2.1.1.4. verzióban jelentették.

Megoldás

Telepítse a javítócsomagokat