IPsec-tools sérülékenység

CH azonosító

CH-12254

Angol cím

IPsec-tools vulnerability

Felfedezés dátuma

2015.05.18.

Súlyosság

Közepes

Érintett rendszerek

IPsec
Linux

Érintett verziók

IPsec-tools 0.8.2
Linux Kernel 2.6-es és előző verziók

Összefoglaló

0-day sérülékenységet találtak az IPsec racoon moduljában.

Leírás

A racoon felel az IKE kulcs kezelő protokol megfelelő használatáért, létrehozza a biztonságos feltételeket a hostok kapcsolódásához.
A racoon összeomlását egy NULL dereference pointer okozza a gssapi.c-ben (Szükséges hogy a HAVE_GSSAPI fordításidejű beállítás definiálva legyen).
A támadás két UDP csomaggal kivitelezhető és az IKE daemon leállását vagy újraindulását eredményezheti.
A támadási kisérletek esetén a szerver naplóban segmentation fault hibaüzenetek jelennek meg. 

Megoldás

Amennyiben hozzáfér a szofver forráskódjához, a hibát egy kivételkezelési sor beszúrásával korlátozhatja.
Mivel az IPsec legutóbbi verzióját 2014-ben adták nem várható jelentős frissítés a szoftverhez.
Ha nem megoldható a problémák megelőzése érdemes lehet alternatív szoftvermegoldásokat keresni  (OpenVPN, Libreswan, strongSwan).

Hivatkozások

Egyéb referencia: www.altsci.com
Egyéb referencia: seclists.org