Joomla! sérülékenységek

CH azonosító

CH-9040

Angol cím

Joomla! Multiple Vulnerabilities

Felfedezés dátuma

2013.04.24.

Súlyosság

Közepes

Érintett rendszerek

Joomla
Joomla!

Érintett verziók

Joomla! 2.x, 3.x

Összefoglaló

A Joomla! több sérülékenységét jelentették, amiket kihasználva a rosszindulatú felhasználók megkerülhetnek egyes biztonsági szabályokat, illetve a támadók cross-site scripting (XSS/CSS) támadásokat hajthatnak végre, és szolgáltatás megtagadást (DoS – Denial of Service) idézhetnek elő.

Leírás

  1. Az alkalmazás nem megfelelően ellenőrzi a jogosultságokat a privát üzenetek törlésekor. Ezt kihasználva például törölni lehet egyébként nem elérhető üzeneteket is.
  2. Az alkalmazás nem megfelelően ellenőrzi a jogosultságokat az engedélyek megtekintésekor. Ezt kihasználva meg lehet ismerni egyébként nem elérhető jogosultsági beállításokat is.
  3. Bizonyos nem részletezett bemeneti adat nem megfelelően van megtisztítva a felhasználónak történő visszaadás előtt. Ezt kihasználva tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.
  4. A Flash alapú fájlfeltöltővel kapcsolatos bizonyos nem részletezett bemeneti adat nem megfelelően van megtisztítva a felhasználónak történő visszaadás előtt. Ezt kihasználva tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.
  5. A Voting bővítménnyel kapcsolatos bizonyos nem részletezett bemeneti adat nem megfelelően van megtisztítva a felhasználónak történő visszaadás előtt. Ezt kihasználva tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.
  6. Az “unserialize()” függvénnyel kapcsolatos nem részletezett hibát kihasználva szolgáltatás megtagadást lehet előidézni.
  7. A Highlighter bővítménnyel kapcsolatos bizonyos nem részletezett bemeneti adat nem megfelelően van megtisztítva a felhasználónak történő visszaadás előtt. Ezt kihasználva tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységeket a 2.5.10 és 3.1.0 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra