KDE KPDF “FoFiType1::parse()” egész alulcsordulás sérülékenység

CH azonosító

CH-2736

Felfedezés dátuma

2009.12.15.

Súlyosság

Magas

Érintett rendszerek

KDE
KDE Team

Érintett verziók

KDE Team KDE 3.x

Összefoglaló

A KDE KPDF egy olyan sérülékenységét jelentették, melyet a támadók kihasználhatnak a felhasználói rendszerek feltörésére.

Leírás

A KDE KPDF egy olyan sérülékenységét jelentették, melyet a támadók kihasználhatnak a felhasználói rendszerek feltörésére.

A sérülékenységet a xpdf/fofi/FoFiType1.cc “FoFiType1::parse()” függvényének egész alulcsordulás hibája okozza, amelyet kihasználva egy verem túlcsordulást lehet előidézni, ha a becsapott felhasználó megnyitja a speciálisan erre a célra elkészített PDF fájlt.

A sérülékenységet a 3.5.10. verzióban jelentették. Más verziók is érintettek lehetnek.

Megoldás

Használjon más alkalmazást a PDF állományok megtekintésre (pl. Okular)!