Kerberos telnetd puffer túlcsordulásos sérülékenység

CH azonosító

CH-6164

Angol cím

Kerberos telnetd Buffer Overflow Vulnerability

Felfedezés dátuma

2011.12.26.

Súlyosság

Magas

Érintett rendszerek

Kerberos
MIT

Érintett verziók

Kerberos 5.x

Összefoglaló

A Kerberos olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak a sérülékeny rendszer feltörésére.

Leírás

A sérülékenységet a “encrypt_keyid()” függvényben található (libtelnet/encrypt.c) határhiba okozza, amely a szervernek küldött speciálisan kialakított paranccsal kihasználható puffer túlcsordulás okozására.

A sérülékenységet a krb5 1.8. megelőző verziókban és a krb5-appl összes verziójában jelentették.

Megoldás

Frissítsen a legújabb verzióra