Linux kernel sérülékenységek

CH azonosító

CH-12314

Angol cím

Linux kernel vulnerabilities

Felfedezés dátuma

2015.06.08.

Súlyosság

Magas

Érintett rendszerek

Kernel
Linux

Érintett verziók

Linux kernel 4.0.5 előtti verziók

Összefoglaló

Magas kockázati besorolású sérülékenységeket találtak a Linux operációs rendszer kerneljében.

Leírás

A Linux kernel OZWPAN driver szoftverében az alábbi sérülékenységeket fedezték fel:

  • CVE-2015-4001: drivers/staging/ozwpan/ozhcd.c oz_hcd_get_desc_cnf függvénye nem megfelelően kezeli az előjeles Integer adattípust. Távolról kihasználható és a szolgáltatás megtagadását okozhatja.
  • CVE-2015-4002: drivers/staging/ozwpan/ozusbsvc1.c oz_usb_rx és oz_usb_handle_ep_data függvényei hibásan ellenőrzik bizonyos értékek hosszát. Kihasználása tetszóleges kódfuttatást eredményezhet és a szolgáltatás megtagadását okozhatja.
  • CVE-2015-4003: drivers/staging/ozwpan/ozusbsvc1.c oz_usb_handle_ep_data függvény hibájának kihasználása a szolgáltatás megtagadását okozhatja. Egy távoli felhasználó egy speciálisan formázott csomaggal nullával való osztást végrehajtva a szoftver összeomlását érheti el.
  • CVE-2015-4004: a driver hibásan kezeli a csomagok hosszmezőjének ellenőrzését, amelyet kihasználva bizalmas információkhoz juthatnak  a kernel memóriából.

Megoldás

Ismeretlen