Moodle sérülékenységek

CH azonosító

CH-9234

Angol cím

Moodle Multiple Vulnerabilities

Felfedezés dátuma

2013.05.20.

Súlyosság

Közepes

Érintett rendszerek

Moodle
Moodle.Org

Érintett verziók

Moodle 2.2.x, 2.3.x, 2.4.x

Összefoglaló

A Moodle több sérülékenységét jelentették, amelyek közül egynek ismeretlen hatása van, illetve amiket kihasználva a rosszindulatú felhasználók megkerülhetnek egyes biztonsági szabályokat, valamint a támadók bizalmas információkat szerezhetnek.

Leírás

  1. Az alkalmazás nem megfelelően ellenőrzi a jogosultságokat a ZIP fájlok letöltése során, amikor a diákok a feladatokat adják be. Ezt kihasználva le lehet tölteni egyébként nem engedélyezett feladatokat is. A sérülékenységet a 2.4 és 2.4.3 illetve a 2.3 és 2.3.6 közti verziókban jelentették.
  2. Az alkalmazás egy hibáját kihasználva, amely egy weboldalnak a hub-on történő regisztrálása során keletkezik, bizalmas információkat lehet szerezni.
  3. Az alkalmazás nem megfelelően ellenőrzi a jogosultságokat egy blog bejegyzéshez tartozó hozzászólások megtekintésekor. Ezt kihasználva egyébként nem elérhető hozzászólásokat is meg lehet ismerni.
  4. Bizonyos tömb paraméteren keresztül átadott nem részletezett bemeneti adat nem megfelelően van megtisztítva felhasználás előtt. Erről a sérülékenységről jelenleg nem áll rendelkezésre bővebb információ.

A 2-4. sérülékenységeket a 2.4 és 2.4.3, a 2.3 és 2.3.6 illetve a 2.2 és 2.2.9 közti  verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra