Moodle sérülékenységek

CH azonosító

CH-7584

Angol cím

Moodle Multiple Vulnerabilities

Felfedezés dátuma

2012.09.16.

Súlyosság

Közepes

Érintett rendszerek

Moodle
Moodle.Org

Érintett verziók

Moodle 2.1.x, 2.2.x, 2.3.x

Összefoglaló

A Moodle olyan sérülékenységeit jelentették, amelyeket a rosszindulatú felhasználók kihasználva megkerülhetnek bizonyos biztonsági szabályokat és a támadók kihasználva bizonyos rendszer információkat szerezhetnek és megkerülhetnek bizonyos biztonsági szabályokat.

Leírás

  1. Az alkalmazás nem megfelelő módon korlátozza a hozzáférést bizonyos műveletekhez, ami kihasználható témák megjelenítéséhez és elrejtéséhez, illetve az aktuális téma beállításához.
    A sérülékenység sikeres kihasználásához szükséges kurzus szerkesztési (course editing) képesség.
    Ezt a sérülékenységet a 2.3 és 2.3.1+ közötti illetve a 2.2 és 2.2.4+ közötti verziókban jelentették.
  2. Az alkalmazás nem ellenőrzi egy blog publikációs állapotát beágyazott fájlok kezelése során, ami kihasználható beágyazott fájlok hozzáféréséhez egy publikálatlan blog esetén.
  3. Az alkalmazás nem megfelelő módon ellenőriz egy bizonyos jogosultságot, ami kihasználható egy kurzus alapállapotba való visszaállításához, az alapállapotba hozó oldal közvetlen hozzáférésével.
  4. Az alkalmazás nem megfelelő módon korlátozza bizonyos függvényekhez való hozzáférést egy webes szolgáltatás tokenje esetén, amely egy bizonyos külső szolgáltatásra mutat. Ez kihasználható az egyébként korlátozott funkciók hozzáféréséhez.
    A 2. és 4. közötti sérülékenységeket a 2.3 és 2.3.1+ közötti, 2.2 és 2.2.4+ közötti, valamint 2.1 és 2.1.7+ közötti verziókban jelentették.
  5. Az alkalmazás a theme/yui_combo.php-ben kezelt nem szabályos kérések során a teljes telepítés útvonalat megjeleníti egy hibaüzenetben.
    Ezt a sérülékenységet a 2.3 és 2.3.1+ közötti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra