nss-pam-ldapd puffer túlcsordulásos sérülékenység

CH azonosító

CH-8502

Angol cím

nss-pam-ldapd File Descriptor Handling Buffer Overflow Vulnerability

Felfedezés dátuma

2013.02.18.

Súlyosság

Alacsony

Érintett rendszerek

N/A
nss-pam-ldapd

Érintett verziók

nss-pam-ldapd 0.x

Összefoglaló

Az nss-pam-ldapd egy sérülékenységét jelentették, amit kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenységet egy tömb indexelési hiba okozza, amely az FD_SETSIZE és az NSS keresések (lookup) kezelése közben keletkezik. Ezt kihasználva verem alapú túlcsordulást lehet előidézni.

A sérülékenység sikeres kihasználásával tetszőleges kódot lehet végrehajtani, de ehhez szükséges, hogy az alkalmazás végrehajtsa az NSS keresést.

A sérülékenységet a 0.7.18 és 0.8.11 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra