OpenPKG biztonsági frissítése javítja az OpenLDAP távoli szolgáltatás megtagadást okozó sebezhetőségét

CH azonosító

CH-205

Felfedezés dátuma

2006.11.11.

Súlyosság

Közepes

Érintett rendszerek

OpenPKG
OpenPKG Corporation

Érintett verziók

OpenPKG Corporation OpenPKG 2.3.x

Összefoglaló

Az OpenPKG kiadta az OpenLDAP-ban azonosított sebezhetőségek javítását. Ezt a hiányosságot a támadók szolgáltatás megtagadás okozására aknázhatják ki.

Leírás

Az OpenPKG kiadta az OpenLDAP-ban azonosított sebezhetőségek javítását. Ezt a hiányosságot a támadók szolgáltatás megtagadás okozására aknázhatják ki.

A sebezhetőség lehetővé teszi, hogy egy távoli támadó szolgáltatás megtagadást okozzon bizonyos LDAP “Bind” kérésen keresztül, ami az “libldap”-ban egy hibás következtetést idéz elő. A hiányosságot a normalizált név hosszának téves kiszámítása okozza.

A sérülékenység a 2.3.28. és a korábbi verziókat érinti.

Megoldás

Frissítsen a legújabb verzióra

Hivatkozások

Egyéb referencia: www.vupen.com
Gyártói referencia: www.openpkg.com
Egyéb referencia: www.vupen.com