OpenSSH sérülékenységei

CH azonosító

CH-12546

Angol cím

OpenSSH vulnerabilities

Felfedezés dátuma

2015.08.23.

Súlyosság

Közepes

Érintett rendszerek

OpenSSL
OpenSSL Software Foundation

Érintett verziók

OpenSSH 6.x, non-BSD verziók
OpenSSH 6.8/6.9

Összefoglaló

Az OpenSSH sérülékenységeit jelentették, amelyeket kihasználva a támadók szolgáltatás megtagadást idézhetnek elő és kiterjesztett jogosultságokat szerezhetnek.

Leírás

Az egyik sérülékenység az OpenSSH 6.8/6.9 verzióban lévő sshd komponenst érinti, és bemeneti adat manipulálásával lehet szolgáltatás megtagadást előidézni.

Egy másik sérülékenység a 6.0-ig terjedő nem-BSD verziókat érinti, és a monitor.c fájlban található mm_answer_pam_free_ctx függvény use-after-free típusú hibája okozhat jogosultság kiterjesztést.

Egy további jogosultság kiterjesztést eredményező hiba szintén az sshd komponenshez tartozó monitor.c fájlbeli függvényben található. Ez a hiba is csak a non-BSD 6.x verziókat érinti.

Megoldás

Frissítsen a legújabb verzióra

Megoldás

Upgrade: OpenSSH 7.0