openSUSE Srvx egész túlcsordulásos sérülékenysége

CH azonosító

CH-11592

Angol cím

openSUSE Srvx integer overflow vulnerability

Felfedezés dátuma

2014.09.04.

Súlyosság

Közepes

Érintett rendszerek

SUSE
openSUSE

Érintett verziók

openSUSE srvx 1.3.1

Összefoglaló

Az openSUSE Srvx sérülékenysége vált ismertté, amelyet kihasználva a támadók szolgáltatás megtagadást idézhetnek elő.

Leírás

Az srvx HelpServ moduljában (mod-helpserv.c) az EmptyInterval paraméter ellenőrzése nem megfelelően történik, így egy nagy értéket megadva szolgáltatás megtagadást lehet előidézni. 

Megoldás

Frissítsen a legújabb verzióra