Oracle Database sérülékenységek

CH azonosító

CH-7765

Angol cím

Oracle Database Multiple Vulnerabilities

Felfedezés dátuma

2012.10.16.

Súlyosság

Közepes

Érintett rendszerek

Database
Oracle

Érintett verziók

Oracle Database 10.x, 11.x

Összefoglaló

Az Oracle Database több sérülékenységét jelentették, amiket kihasználva a rosszindulatú, helyi felhasználók módosíthatnak bizonyos adatokat és szolgáltatás megtagadást (DoS – Denial of Service) idézhetnek elő, a rosszindulatú felhasználók illetve támadók bizalmas információkat szerezhetnek, módosíthatnak egyes adatokat és feltörhetik a sérülékeny rendszert.

Leírás

  1. A Core RDBMS komponens egy nem részletezett hibáját kihasználva bizalmas adatokat lehet szerezni és módosítani, illetve tetszőleges kódot lehet futtatni. A sérülékenység egy korábbi hibával kapcsolatos, amelyről az alábbi hivatkozáson található bővebb információ:
    CERT-Hungary CH-5781
  2. A Core RDBMS komponens egy nem részletezett hibáját kihasználva egy hitelesített felhasználó bizalmas adatokat szerezhet vagy módosíthat, illetve tetszőleges kódot futtathat. A sérülékenység sikeres kihasználásához Create session, create table jogosultság szükséges.
  3. A Core RDBMS komponens egy nem részletezett hibáját kihasználva egy hitelesített felhasználó bizalmas adatokat szerezhet vagy módosíthat, illetve tetszőleges kódot futtathat. A sérülékenység sikeres kihasználásához Create session, create table jogosultság szükséges. A sérülékenység egy korábbi hibával kapcsolatos, amelyről az alábbi hivatkozáson található bővebb információ:
    CERT-Hungary CH-7349
  4. A Core RDBMS komponens egy nem részletezett hibáját kihasználva egy helyi felhasználó módosíthat egyes adatokat és a komponens összeomlását idézheti elő.
  5. A Core RDBMS komponens egy nem részletezett hibáját kihasználva egy hitelesített felhasználó módosíthat bizonyos komponensek által hozzáférhető adatokat. A sérülékenység sikeres kihasználásához Create session, create table jogosultság szükséges

A sérülékenységek a 10.2.0.3, 10.2.0.4, 10.2.0.5, 11.1.0.7, 11.2.0.2 és 11.2.0.3 verziókban jelentették.

Megoldás

Telepítse a javítócsomagokat